lunes, 30 de diciembre de 2013

El Protocolo Fantasma

por Julio Sale Yalis

La historia de los protocolos de Internet (Interconnected Network – Redes Interconectadas) es algo tediosa y compleja. Para simplificar, diremos que se inició en los años sesenta con NCP (Network Control Protocol – Protocolo de Control de Redes) un protocolo que utilizaba ARPANET para intercomunicar sus hosts. Algo más tarde, en los años setenta, comenzaron a diseñarse la familia de protocolos que dio en llamarse TCP (Transmission Control Protocol – Protocolo de Control de Transmisiones), el cual en los años ochenta reemplazaría a NCP en forma definitiva.

IPv5 - Un Protocolo Enigmático.
TCP desde la versión 1 evolucionó hasta la flamante versión 6. La versión 2 incluyó diversas mejoras, pero no dejó de ser experimental. La versión 3 fue algo desarrollista e introdujo la división IP (Internet Protocol – Protocolo de Internet) que haría famoso a este protocolo, de esta forma las transmisiones en Internet comenzaron a conocerse como el conjunto de protocolos TCP/IP. La versión 4 fue lo máximo, el estándar por excelencia que dominó la Red de Redes durante más de 30 años y, siendo que hay todavía muchos dispositivos que no migrarán a la versión 6, es de suponer que habrá IPv4 por al menos unos 15 años más.

Los protocolos se definen en los RFC (Request For Comments) y en los IEN (Internet Experiment Note). IPv4 está definido en el RFC 791/81, fue elaborado por el IETF (Internet Engineering Task Force) y reemplazó totalmente al protocolo descrito en el RFC 760/80 del DoD SIP (Department of Defense Standard Internet Protocol [USA]).

Además de ser el protocolo más famoso del mundo, IPv4 es sumamente ágil y versátil. Sin embargo, el crecimiento impensado de Internet a partir del año 2000, puso las cosas realmente difíciles para este protocolo, llevándolo prácticamente al borde del colapso de las direcciones de red y dejando a IPv6 al acecho. Así, llegamos a nuestro tema principal.

IPv5 - ¿ ... ?.
Debido a las limitaciones técnicas de direccionamiento, se hizo necesario la revisión de IPv4. El resultado fue IPv6. Pero, ¿y por qué no IPv5?

Según se indica en los IEN y RFC, surge a fines de la década de los setenta un nuevo protocolo denominado ST (Internet Stream Protocol), que conformaría la familia: ST, ST2 y ST2+. (!)

Concretamente, el IEN 119/79, define al protocolo ST, creado por James Forgie del MIT (Massachusetts Institute of Technology), como una extensión del protocolo IP, que brindaría soporte de QoS (Quality of Service), especialmente para aplicaciones de comunicación punto a punto de voz y video conferencia.

Posteriormente el RFC 1190/90, actualiza el IEN 119 y redefine al protocolo ST, considerándolo de uso experimental, y le asigna la versión 2. Si bien el mismo no es compatible con la versión 1, mantiene gran parte de su filosofía y arquitectura, a la vez que ofrece mayor facilidad de implementación.

Los Primeros Cuatro Bits.
Por último, el RFC 1819/95, vuelve a definir a ST como un protocolo experimental, dejando expresamente indicado que no se trata de un estándar. Además, aclara, simplifica y corrige errores de la versión anterior y le asigna a ST la versión 2+ (2 plus). Pero lo notable, es que indica también que el protocolo se encuentra aún en desarrollo y, que desde su aparición, no se han logrado avances significativos ni implementación real alguna. Esta última revisión del protocolo ST fue realizada por el IETF.

Ahora bien, ¿qué tiene que ver ST con IP?

Simplemente, nada. De hecho ST e IP pueden coexistir, no son excluyentes, y una misma aplicación multimedia estándar puede utilizar ambos protocolos. Para complicar aún más las cosas, los mensajes de ST pueden ser encapsulados en paquetes IP. (!)

Entonces, ¿dónde está el truco?

Develando el Desconcierto.
Ok, veamos. Los paquetes de ambos protocolos difieren en los primeros cuatro bits, los cuales identifican a la versión del protocolo que se está implementando. Como ST es un protocolo independiente y funciona de tal manera, para distinguirlo había que asignarle un número de versión. El estándar de la Red (IP), ya estaba utilizando el número de versión 4, motivo por el cual el IETF, en el mismo RFC, deja expresamente reservado el número de versión 5 para ST. De esta forma, cuando se realizó la revisión de IPv4, se le asignó a la nueva versión el número 6, puesto que ST había sido coronado con el número de versión 5 del protocolo IP. ¿Ha sido esto un error? Es muy probable, aunque también discutible.

Te preguntabas qué fue de IPv5 y no podías dormir pensando en ello. Bien, como lo prometido es deuda, te traje la respuesta. Aunque, para muchos, IPv5 continuará siendo el protocolo fantasma.

Eso es todo.

No hay comentarios.:

Publicar un comentario